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Copyright 
 
©2002-2010 Premier Assistive Technology, Inc.  All Rights Reserved.  This 
documentation and the accompanying software are copyrighted materials.  
Making unauthorized copies of this material is prohibited by law.  No part of the 
software or documentation may be reproduced, transmitted, transcribed, stored 
in a retrieval system or translated into any human or computer language without 
prior written permission of Premier Assistive Technology, Inc.  Premier Assistive 
Technology, Inc. asserts its "Moral Right" to be identified as the author of this 
work, in all jurisdictions which recognize the "Moral Right." 
 

 Notice 
 

Unless otherwise provided by written agreement with Premier Assistive 
Technology, Inc., this publication, and the software sold with this publication are 
provided "as is" without warranty of any kind either expressed or implied, 
including but not limited to the implied warranties of merchantability and fit this 
particular purpose.  The entire risk arising out of the use or performance of this 
publication and software remains with you.  In no event will Premier Assistive 
Technology Inc., or any of its suppliers, be liable for any lost profits, lost savings, 
direct, incidental or indirect damages or other economic or consequential 
damages, even if Premier Assistive Technology, Inc., or its suppliers, have been 
advised of the possibility of such damages.  Premier Assistive Technology, Inc. 
reserves the right to modify this document at any time without obligation to notify 
anyone. In no event shall Premier Assistive Technology, Inc. or its suppliers' 
liability under this agreement exceed the sum of any amounts paid hereunder by 
the customer to Premier Assistive Technology, Inc. or the supplier. 

 
WordNet 1.7.1 - Copyright 2001 by Princeton University.  All rights reserved.  
This software and database is provided "as is" and Princeton University makes 
no representations or warranties, express or implied.  By way of example, but not 
limitation, Princeton University makes no representations or warranties of 
merchantability or fitness for any particular purpose or that the use of the 
licensed software, database or documentation will not infringe any third party 
patents, copyrights, trademarks or other rights.   

 
Trademarks 
 

Mac, Mac OS, the Mac logo, and Safari are trademarks of Apple Inc., registered 
in the U.S. and other countries. Premier Literacy is a registered trademark of 
Premier Assistive Technology, Inc. 

 
You shall not use any of the Trademarks or Service marks of Premier Assistive 
Technology, Inc., Apple Inc., or any other entity, without the express written 
permission of such Trademark or Service mark owner. 
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Deletion or Modification 
 
If any portion of this Manual, including but not limited to the "Notice" section 
above, is held to be unenforceable, then that portion shall be deleted, and the 
remaining language shall be given its broadest legal effect. 

 
Corporate Addresses 
 
Premier Assistive Technology, Inc. Premier Assistive Canada 
1309 N. William St. P.O. Box 875, STN A 
Joliet, IL 60435 Sydney, NS   B1P 6J4 
USA Canada 
Phone: 815-927-7390  Phone: 902-482-4680 
Fax: 815-722-8802 Fax: 902-270-5224 
E-mail: info@readingmadeeasy.com  Email: info@readingmadeeasy.ca 
Web: www.readingmadeez.com Web: www.readingmadeeasy.ca 
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What is the Ultimate Talking Dictionary? 
 
The Ultimate Talking Dictionary (UTD), first and foremost, is a comprehensive dictionary.  
However, this is not a regular dictionary; it has a number of additional features that may 
surprise you.  The UTD can actually “read” aloud the definition of a word.  The total 
dictionary that comes with the UTD contains over 250,000 words, including slang, 
jargon, and even names of historic figures (e.g., George Washington, Martin Luther 
King).  The UTD also has a fully integrated thesaurus for referencing synonyms and 
antonyms of all words. 
 
How does this compare to a standard dictionary? A standard desktop dictionary contains 
about 110,000 words with definitions and is about 800 pages.  However, the UTD also 
includes sentences using each defined word in context, for every “sense (meaning)” of 
the word.  Can your desktop dictionary read the definition to you?  Can you make your 
dictionary into large print?  Does your dictionary provide you with a list of synonyms for 
the word you are looking for?  Does your dictionary tell you if the word you are looking 
for is misspelled and provide you with the correct spelling?  If the answer is “No” to any 
of these questions, you will immediately realize the power of the Ultimate Talking 
Dictionary. 
 

More than a Dictionary – Interlink Technology 
 
The UTD is more than just a dictionary.  With the UTD, you do not need to know the 
exact spelling of a word.  You just need to know some of the letters in the word.  If you 
try to look up a word that you have misspelled, the “Did You Mean? List” will appear, 
giving you a list of words that you may have meant to spell.  Use your arrow keys to 
move through the list to hear each possible word and see if that is the one you want.  If 
you find the word you want, simply press the Return key to look it up.   
 
Now you can look up a word even if you are not sure of the word you need. That’s right-- 
you can find a word without knowing the word itself.  Look up a word by just knowing a 
vague idea about the word!  For example, you may want to look up a type of “cloud”, but 
can’t think of the name of that type of cloud.  You may know what the cloud looks like, 
the shape, the color, etc., but still only know that it is a cloud.  To help you find the word 
you’re searching for, just enter the word “cloud” and UTD will give you not only the 
definition of a cloud, but it will also list all the different “types of” clouds.  In another 
example, you can start by looking up “sky”. You can view all the parts of the sky such as 
“rainbow” and “clouds”.  You can then select “clouds” and then view the types of clouds.  
Using this approach, you can find a definition of an “acorn” just by looking up “oak tree”. 
 
Use your arrow keys to search through the list of “types” and listen to pronunciation of 
the word describing the cloud that you want.  Once you hear the word you’re looking for, 
press the Return key to look up the definition of that cloud to verify that this is indeed the 
type of cloud you intended. 
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To enable such powerful searching algorithms, all of the words in the UTD are 
“interlinked” in a myriad of ways to allow cross-referencing on a variety of relational 
levels so it’s easy to find a word just by knowing a concept or related idea.  Getting a 
definition of the word is great, but being able to easily find a word that you don’t know is 
even better.  Have you ever had a word at the tip of your tongue, but could not get it out?  
How many times have you said, “Well, it’s one of those ‘things’ when you couldn’t come 
up with the proper word?”  This is a fairly common occurrence for many individuals.  
They know the concept or object, but the exact word escapes them.  They know what it 
is and will know it when they see it or hear it, but they just need help locating it.  A 
traditional dictionary would never help you with this.  But with the UTD, you can find 
something just knowing a concept or idea and using the UTD’s Interlink technology to 
search through word relationships until you find the exact word you are looking for.    

Features 
 

250,000 words: The UTD comes with a comprehensive standard dictionary that 
contains over 250,000 words.  When a word definition is provided, it is often 
accompanied by a sentence using the word in context for each sense / meaning 
of the word.  The definitions are clearly written so that a wide range of age 
groups can understand them. 
 
Spelling:  Have you ever tried to look up a word, but can’t find it because you 
have misspelled it? The UTD can assist you.  If you misspell a word, the UTD will 
“predict” the word you are trying to spell and present you with a list of potential 
matches for the word you are trying to find.  Once you “select” the word you want 
from the list of possible matches, the UTD will read the word you have selected 
so you can be sure that it indeed is the word you want. You can then have the 
UTD retrieve and display the definition for you. 

 
Reading: The UTD will read the definitions to you so that you can hear the 
meaning of a word.  It can also highlight the word on the screen as it reads.  Both 
the “synonym” list and the “word prediction” list speak. Just click on a word to 
have it read to you. 
 
Power search:  If you do not know how to spell a word, but know part of the 
word, you can do a “power search”.  A “power search” gives you the ability to 
specify just a few letters and then let you search for ALL words that either “start 
with”, “end with” or “contain” the letters you choose. UTD will provide a list of all 
the words that contain that sequence of letters.   Using the Up and Down Arrows 
on the keyboard, listen to the list of words one at a time.   

 
Thesaurus:  Until now, dictionaries and thesauruses have almost always been 
separate books / documents.  With the UTD there is a built-in thesaurus that will 
automatically look up alternative words or “synonyms” every time you search a 
word.  If you want to hear a definition of a synonym, just double-click it. 

 
Zoom:  To squeeze the maximum number of words into a dictionary, many 
publishers often print dictionaries using smaller fonts than a person would 
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typically find in a newspaper, magazine or book. The UTD can be made into a 
large print dictionary without any reduction of its total contents. The “zoom” 
feature allows you to enlarge the print to meet your needs without reducing the 
number of words in the UTD. 

 
Word History:  The UTD keeps a current “word session history”. Have you ever 
used a dictionary where the definition tells you to look up another word, or it 
gives you a definition that requires you to look up more words to understand that 
definition?  The UTD keeps a history of all the words you look up in a particular 
online session so that you can easily go back to the previous word just by 
clicking on the Back icon, just like you would when using a web browser.  
 
Accessibility: The UTD is designed to work with screen readers and screen 
magnifiers.  The voice can be “turned off” so that it will not interfere with a screen 
reader voice.  After all, if you have a screen reader, you do not need another 
program that talks. The UTD can also be used with just simple keyboard 
commands and does not require the use of a mouse. (See Appendix B for a 
quick reference of keyboard combinations.) 
 
Antonym Support:  The UTD has a very robust Antonym support as part of the 
overall Interlink features, because it matches up the correct antonym with the 
correct sense of a word.  (Note: Antonyms are only displayed when the selected 
word actually has an antonym.  For example, there is no antonym for the word 
PURPLE). 

 

How does it work? 
 
You can use the UTD in several ways.  You can use it as a traditional dictionary where 
you type in a word and it looks it up for you. To look up a word in the synonym list or in 
one of the Interlink tabs, double-click the word or Ctrl + Click a selected word and use 
the contextual menu to run a search. 
 
Every time the UTD looks up a word, it automatically uses its powerful thesaurus to try to 
find any synonyms for that word.  The dictionary and thesaurus are truly integrated.   To 
find a definition of a synonym, all you have to do is double-click the synonym.  The built-
in Back and Forward icons allow you to easily get back to the original word by moving 
through the word history list. 
 
Sometimes dictionaries create more questions than they answer. If you are ever 
presented with a definition that contains words you do not understand, just search for the 
word you do not understand, and that new word’s definition will be presented to you.  To 
go back to the previous word, click the Back icon. 
 
We often understand something better when we hear it.  The UTD reads the definitions 
out loud. This is extremely helpful if you have reading difficulties or are learning English. 
As it reads, it will highlight each word in the definition to help you follow along.  The UTD 
gives you several options for how it will read.  You can even turn the voice off. 
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The Program 
 
The Ultimate Talking Dictionary “UTD” is a handy utility that works like most other 
programs. The UTD only has one main screen to keep the interface simple.  The toolbar 
at the top of the screen contains all the major functions for the UTD. 

 
 
You will find almost everything you need on the toolbar. Each icon on the toolbar has a 
keyboard alternative, so if you can’t use the mouse, you can still activate the icons with 
corresponding keystrokes.   
 
The UTD window is separated into several main sections: 
 

 The Toolbar is near the top of the window and contains the icons to access 
key features of the UTD. 

 The Lookup Word area is just below the Toolbar.  In the Lookup Word field, 
just type in the word you want to look up and then press the Return key or 
click the Look Up icon. 

 The Look For area allows you to select definitions to display based on an 
article of speech such as Noun, Verb, Adjective, etc.  The default is to display 
ALL articles of speech for a definition. 



 Ultimate Talking Dictionary Mac User Manual 
Premier Literacy 

 10 
 

 The Definition area contains all the definitions for a word.  Definitions are 
always presented in this order: Noun senses, verb senses, then adjectives 
and adverbs.  You can hear the definition simply by clicking the Read icon or 
pressing Command + R.  You can also use your arrow keys to read line by 
line. 

 On the right hand side of the window, you will see the Synonym list. Every 
time a word is looked up, the UTD finds as many synonyms as it can and 
puts them in this list. If you want to find a definition of a word in the synonym 
list, just double-click it and the definition will appear in the Definition window.  
Click the Back icon to go back to the original word. Click the Forward icon to 
return to the synonym word.  For a list of antonyms, you will need to click the 
Antonym tab in the Interlink section at the bottom of the screen.  The 
Antonym tab only appears if the original word you selected has antonyms 
associated with it.  For example, the word PURPLE has no antonyms, so the 
Antonym tab will not appear in the Interlink section at the bottom.  

 

 Interlink - additional information about a word 
 

All of the words in the UTD are “interlinked” in a myriad of ways to allow cross-
referencing on a variety of relational levels so that it is easy to find a word just by 
knowing a concept or related idea. With our special Interlink technology, when you 
look up a word, the UTD will provide you with more information than just the 
definition.  In the example below, we look up the word “cloud” .a very generic word.  
The following sections are provided to give you all the information you would need 
about “cloud”.  After you look up a word, you will see a series of tabs across the 
bottom of the screen. The number of tabs displayed may vary based on the word 
being looked up since each word has a unique set of relationships with other words 
in the UTD.  The following examples are some of the most common relationships 
often seen between words in the UTD: 

Parts 
 
Some words may represent ideas or concepts that consist of “parts” of other 
ideas or concepts.  In the case of “cloud”, on the “Parts” tab you will see the 
words corresponding to “parts” that make up a cloud. In this case you will see 
“water vapor” and “water vapour” (the British spelling). 
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Type of 
 
The “Type of” tab represents a list of words or phrases that may describe larger, 
more generalized groups of related ideas or concepts.  Your selected word will 
be a subset of one or more of these “groups”.  For example, “cloud” could be 
considered to be part of a bigger group of concepts known as “atmospheric 
phenomenon”.  Other words like “wind”, “rain” and “snow” may also be part of this 
same group of related words.  Words or phrases appearing under the “Type of” 
tab should not be confused with a synonym, which is a word that has a similar 
basic definition.  Again, to further explain, “cloud”, “wind” and “rain” are all 
considered “atmospheric phenomenon”, but they certainly are NOT synonyms for 
each other. 

 
 

 
 

Types 
 
“Types” are very useful.  For example, you may be looking for a type of cloud, 
but you do not know the name. All you know is that it is a cloud. Look up the 
word “cloud”. Then go to the “Types” tab, and it will list all the types of clouds.   
You can narrow your search by selecting the type you are looking for from the 
Look For list (the upper right-hand corner of the UTD screen).  You can look for 
just the noun, verb, adverb or adjective form of a word. 

 

 
 

Part Of 
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“Part of” is a valuable feature that can be used to explore situations where the 
word you are searching is “contained in” or “part of” something else.  If you look 
up the word “cloud” and select the “Part of” tab, you will see that a “cloud” is part 
of the “sky”.   
 

 
 

See Also 
 

In dictionaries you will frequently see a section called “see also”.    The “See 
Also” section gives you a list of words that may give you additional information 
about concepts and ideas that may be related to the word you are researching. 

 

 
 

Antonym 
 

The antonym tab will only appear if there is an antonym for the word you just 
looked up.   
 

Look For 
 

Look For is a drop-down list from which a specific type or sense of the word can be 
selected.  By default, when you look up a word, it gives you ALL senses of the word.  
This includes nouns, verbs, adjectives, adverbs, pronouns, conjunctions, 
prepositions and interjections.  When “Noun” is selected, only the definitions for a 
noun are displayed.  Switching to “Verb” only shows verb definitions.  The “Look For” 
feature works this way for all “senses” of words in the UTD. 
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Ultimate Talking Dictionary Menu 
 
The Ultimate Talking Dictionary menu contains selections for Preferences for reading 
and voice options, for viewing the product version information in the About Box, and to 
Quit the application. 

 About Ultimate Talking Dictionary 
 

To determine the version of UTD being used, select About Ultimate Talking 
Dictionary from the Ultimate Talking Dictionary menu. The version information may 
be helpful if you contact Technical Support.  

 

 
 

 Preferences 
 
Select Preferences to make changes to the reading and voice options for the UTD. 

 Options 

To set reading options, either click the Options icon  on the interface or select 
Preferences from the UTD Menu.  The reading options window allows you to 
adjust how the UTD reads. 
 

 
 

There are four reading options and each item is turned on or off by its check box. 
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If there is a check in the check box, the option is turned ON. 
 
Voice On:  If Voice On is not checked, all voice activity is stopped.  If you are 
using other screen reader software, it is recommended that you turn this option 
OFF.  The default is ON. 
 
Automatically Read Definition:  If this option is turned ON, the UTD will start 
reading the definition aloud as soon as the definition is retrieved and displayed in 
the Definition window.  There is no need to click the Read icon to hear the 
definition if this option is checked.  The default is ON. 

 
Read Line By Line:  If you want to use the UP and DOWN arrow keys to read 
one line at a time in the definition area, turn this option ON. The default is ON. 
 
Turn On Word Tracking:  When this option is ON, each word is highlighted as it 
is read. 
 

 Voices 
 
The UTD can access any installed digital voices on your computer.  You can 

change the voices at any time by clicking the Voices icon on the interface or 
by selecting Preferences from the UTD menu and clicking on the Voices icon.  
This opens the Voice settings window: 
 

 
 
Use the Voices drop-down menu to select the desired voice. 
 
Once a voice is selected, the rate can be adjusted by moving the Voice Rate 
slider to the right for faster and to the left for slower. Click the Test button to hear 
what the new settings sound like.  The voice only needs to be reset when a 
change to the voice is desired.  The system remembers the last setting each time 
the system is started.  Once the desired voice setting is set, it will rarely need to 
be changed again. 
 
Click the OK button to close the window and save the changes.  To close the 
window without saving any of the changes, click the Cancel button. 
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 Quit Ultimate Talking Dictionary 
 

Selecting Quit Ultimate Talking Dictionary from the Ultimate Talking Dictionary menu 

will close the UTD. Clicking the Close icon  on the toolbar is another way to 
close the UTD. 
 

File Menu 
 
In the File menu, you will find everything you need to create a new search or do a 
“power search”. 
 

 New Search 
 
Begin a new search by selecting New Search from the File menu.   This will clear the 
screen.  This does not need to be done for every search.  Just type in the new word 
to be found and click the Look Up button. The UTD will clear everything for you. 
 

 Power Search 
 

Power Search allows you to search for a word when you only know how to spell part 
of the word.  Either select Power Search from the File menu or click the Power 

Search icon .  Type in the letters you want to find.  Select the desired search 
method.  You can search for a word that begins with, ends with, or contains the 
letters you enter in the Lookup box.  Click the Search button and a list of words will 
appear in the definition box. 
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Edit Menu 

 Cut 
To cut text from the definition window, select the desired text you want to cut and 
then select Cut from the Edit menu.  

 Copy 
To copy text from the definition window, select the desired text you want to copy and 
then select Copy from the Edit menu.  

 Paste 
To paste text into the definition window, place the cursor where you want to paste 
the text and then select Paste from the Edit menu.   

 Delete 
Select Delete from the Edit menu to delete selected text in the Lookup Word field. 

 Select All 
To select all the text in the definition window, place the cursor in the definition 
window and choose Select All from the Edit menu. 
 

History Menu 

 Backward 
 
The UTD keeps a “word history”.  This allows you to keep a list of all the words 

looked up during the current session.  Use the Back icon  to go back through the 
list of words.  

 Forward 

Use the Forward icon  to go forward through the word history list.  When you get 
to the most recently used word, it will not go any further forward. 

 Word history 
 

The UTD keeps a “word history”. The word history is tracked internally and you can 

go back  or forward  through the list. The History menu also keeps track of 
the 10 most recently searched words in the current session. 
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Read Menu 

 Read 

Click the Read icon to have the UTD start reading the definition aloud.  UTD 
will read the entire definition. To read only a part of the definition, click in the 
definition area where you want to start reading and then use the UP and DOWN 
arrows to read the next or previous line. 
 

 Pause 

Click the Pause icon  to temporarily stop the UTD from reading, but still hold 
its place in the document.  To resume reading after clicking Pause, simply click the 
Read icon again. 

 Stop 

Click the Stop icon  to stop the UTD from reading.  If the Read icon is clicked 
again, the UTD will start reading from the beginning. 
 

Zoom Menu 
 
The zoom feature allows you to make the UTD a “large print” dictionary. When you go to 
the bookstore and purchase a large print dictionary, you have to give up 
something and that typically means fewer words.  The average Large Print dictionary 
only contains 35,000 – 40,000 words, compared to the standard desktop dictionary that 
contains about 110,000 words. 

 Zoom Out 
 
To reduce the font in UTD, select Zoom Out from the Zoom menu or click the Zoom 

Out icon  .   
 

 Zoom In 
 
To increase the font in UTD, select Zoom In from the Zoom menu or click the Zoom In 

icon .   
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Every time the Zoom In/Out icons are clicked, the font size of all the screen areas 
including the Lookup Field, Synonym Field and the Definition area will increase or 
decrease.  The font size ranges from 13 point to 25 point. 
  

Help Menu 
 

 Ultimate Talking Dictionary Help 
 
This entire manual is available in .pdf format.  To activate Help, select Ultimate 

Talking Dictionary Help from the Help menu or click the Help icon . 
 

 Watch a Training Video 
 
Select “Watch a Training Video” from the Help Menu to view a video tutorial on how 
to use the Ultimate Talking Dictionary. 
 



 Ultimate Talking Dictionary Mac User Manual 
Premier Literacy 

 19 
 

Appendix A – System Requirements 
 

 Operating System:  Mac OS X 10.4 or higher 

 CPU: 2 GHz Intel Core or faster 

 Memory: 512 MB of RAM recommended 

 Internet Browser: Safari 4 or higher (if reading web pages) 

 CD-ROM Drive:  4X or Faster (only required if installing from CD) 



 Ultimate Talking Dictionary Mac User Manual 
Premier Literacy 

 20 
 

Appendix B – Key Combinations 
 

RETURN Look up the word in the lookup field 
CMD + R Start reading 
CMD + S Stop reading 
CMD + P Pause 
CMD + A Select All 
CMD + X Cut 
CMD + C Copy 
CMD + V Paste 
CMD + Shift + P Power Search 
CMD + N New Search 
CMD + [ Move to previous word 
CMD + ] Move to next word 
CMD + , Preferences 
CMD + Shift + + Zoom Out 
CMD + Shift + - Zoom In 
CMD + Q Quit 
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